Google+

We Recommend By ZergNet

27 comments

  • MrXakaRebel - November 16, 2012 2:18 p.m.

    Am I the only one having trouble submitting my entry? It's just perpetually showing the loading symbol when I hit enter..
  • ZuzuPachulia - November 16, 2012 3:11 p.m.

    Same problem here, had the same problem with the last giveaway too.
  • MrXakaRebel - November 16, 2012 3:15 p.m.

    They should just count us as 2 of the winners for being loyal enough to keep trying...=P
  • Person5 - November 16, 2012 6:10 p.m.

    I also has this issue, do I get an automatic win too?
  • GR_SophiaTong - November 16, 2012 10:20 p.m.

    is it still happening? Are you on mobile or a desktop?
  • Person5 - November 17, 2012 12:31 a.m.

    I got mine to work using Firefox. I use Chrome though which I bet these other two fine gents were using too. So its prolly just a Chrome problem, though what I saw on FB people seem to also have problems with IE as well.
  • MrXakaRebel - November 17, 2012 8:51 a.m.

    Yea I'm using chrome on a desktop, still not working for me.
  • codzprc - November 18, 2012 5:04 p.m.

    Though I'm lessening my odds of winning - try a different browser. I had the loading-limbo problem in Chrome, switched to safari and it submitted fine.
  • MrXakaRebel - November 19, 2012 6:26 p.m.

    Your selflessness is much appreciated, I hope we both win...

Showing 21-27 of 27 comments

Join the Discussion
Add a comment (HTML tags are not allowed.)
Characters remaining: 5000

OR…

Connect with Facebook

Log in using Facebook to share comments, games, status update and other activity easily with your Facebook feed.